FPS drop after Alt+tab

Chat about the Ashita v3 project here.
Post Reply
Siushaga
Posts: 15
Joined: Fri Apr 28, 2017 9:49 am

FPS drop after Alt+tab

Post by Siushaga » Sun Feb 11, 2018 8:38 am

Hello,

I've been experiencing some issues lately where I have major FPS drops after alt+tabbing out of the game to Firefox/Chrome to look something up and then alt+tabbing back into my game. I use the Direct3D proxy (viewtopic.php?f=26&t=142) and have 60 fps just fine until I alt+tab then it drops down to 30-35fps with major stuttering/rubberbanding. I either have to use '/fps 2' to play with 30 fps or it usually will resolve itself after I change zone. The issue is reproducable every time I alt+tab to a browser, typically do not see with no browser open and just alt+tabbing to discord or other apps.

For the FFXI config, I have Full screen mode chosen, but should this be windowed or bordlerless windowed? For my Ashita config, it is running in windowed mode without border. Window size, background size and menu size I have all set to 1920x1080 for my native resolution. Laptop settings are set to prefer maximum performance. I've tried things like setting the boot.exe process to above normal or high process priority, as well as tried 3rd party apps like Project Mercury to try to help with the process priorities.

Any ideas if it's just a setting or something simple in a config I might be overlooking? Thanks for any advice!
User avatar
atom0s
Site Admin
Posts: 383
Joined: Sat May 14, 2016 5:13 pm

Re: FPS drop after Alt+tab

Post by atom0s » Sun Feb 11, 2018 10:49 pm

Do you use any type of enhanced game keyboard/mouse or a controller? Sometimes these can cause issues. If so, try disabling any extra software they come with, or that you are using, and see if it still happens. Also try without the proxy and see if you notice a difference too to help see if its isolated to the proxy or the game itself.
Lead Ashita Developer

Want to donate to say thanks?
https://www.paypal.me/atom0s
Siushaga
Posts: 15
Joined: Fri Apr 28, 2017 9:49 am

Re: FPS drop after Alt+tab

Post by Siushaga » Mon Feb 12, 2018 5:34 am

atom0s wrote:
Sun Feb 11, 2018 10:49 pm
Do you use any type of enhanced game keyboard/mouse or a controller? Sometimes these can cause issues. If so, try disabling any extra software they come with, or that you are using, and see if it still happens. Also try without the proxy and see if you notice a difference too to help see if its isolated to the proxy or the game itself.
Thanks for the response. I play on a laptop without any external keyboards or controllers. As for the proxy, I can try playing without it to see if I still see the problem, but I have to use it in order to use my GPU due to Nvidia Optimus... might still be able to see a drop in FPS from alt tabbing even though I will already have bad FPS without the proxy, though. Can try that later today after work.
Siushaga
Posts: 15
Joined: Fri Apr 28, 2017 9:49 am

Re: FPS drop after Alt+tab

Post by Siushaga » Mon Feb 12, 2018 5:12 pm

After a lot of trial and error, it seemed to be isolated to hardware acceleration in my web browsers. I disabled those and I'm not seeing the FPS drop off during alt+tabbing anymore.
Post Reply