Failed to initialize Direct3d

Chat about the proxy project here. (General topics, support, requests, etc. are welcome here.)
Posts: 1
Joined: Mon May 06, 2019 4:25 pm

Failed to initialize Direct3d

Post by dazyk » Mon May 06, 2019 5:36 pm

Hi all, hoping someone can help me..

FFXI crashes with the following error message when it loads from POL:
Terminated as error occurred in Final Fantasy xi. Failed to initialize Direct3d. Please check that this computer has the required specifications to run Final Fantasy xi. (-1)
Obviously, my PC has the specs to run it... I'd been playing it for months on regular ol' settings before I stumbled upon Ashita and Reshade. I have a GeForce MX150 in this laptop, and have been pissed that I can still only seem to get 15-25 fps out of this 20 year old game...

Anyway, I've followed all the instructions on how to install the proxy and I did not change any of the default settings in the .ini. I downloaded all the C++ files (hell, I installed all of them back to 2005... just to be sure). I ran a DXDIAG to see if there was anything wrong... everything read 'No Problems'.

After some research (alright, a LOT of research), I tried to put the .dll and .ini file in the Final Fantasy XI folder AND the Playonline folder (someone in another thread said that that worked for them); didn't work. Tried putting the files ONLY in the Final Fantasy XI folder; didn't work. Tried putting the files in the Ashita boot folder for whatever damn reason... that obviously didn't work.

I've just about exhausted my options... All the googling keeps coming up with the same threads, so I'm not sure what else to do.

Any help would be amazing! Thank you all in advance. Let me know if you need any other diagnostic data.

Posts: 1
Joined: Wed Jun 12, 2019 8:43 am

Re: Failed to initialize Direct3d

Post by alfalahi » Wed Jun 12, 2019 8:48 am

i have the same problem

here what fix it for me

Window size was 1080 x 1920

i switched the numbers to 1920 x 1080

and it worked

good luck